Discover Vulnerable Cisco Devices and Software Versions with LiveNX’s Device Reporting

Cisco announced recently (on December 21, 2015) that there is a specific security vulnerability with software version IOS-XE 16.1.1, which runs on Cisco Catalyst 3850 Series and Cisco Catalyst 3650 switches. Cisco had previously announced software updates to address this vulnerability.

Discover Vulnerable Cisco Devices and Software Versions with LiveNX’s Device Reporting

 

Managing your entire inventory of Cisco devices can be tedious at best, however both existing and prospective
(14-day trial) LiveNX users can leverage LiveNX to easily identify which devices are running the specific versions of software related to this and any other vulnerability announcements and upgrade them.

Below is the step-by-step guide to identify and mitigate this specific vulnerability using LiveAction’s LiveNX.

Step 1

Launch LiveNX client

LiveAction client

Step 2

From the File Menu, select Export Devices > Export

GetFileAttachment-2

Step 3

Visually inspect the list for devices and specific software versions that may contain a vulnerability, or export to CSV for import into Excel for further filtering or sorting.

Step 4

Of particular interest for this vulnerability issue would be the Cisco Catalyst 3850 and Cisco Catalyst 3650 switches running IOS-XE 16.1.1.

For i.e.: A Cisco Catalyst 3850 switch running IOS-XE 3.10.93 which is not vulnerable to this particular issue.

Step 5

Upgrade the IOS-XE version with the latest software from cisco.com

Tweet about this on TwitterShare on FacebookShare on Google+Share on LinkedInPin on PinterestEmail this to someone